package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d*)(.+?)(,)()`)
var str = `1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,
FIRST DISPLAY BLOCK REGEX COMMAND
[REPLACEALL](\d*)(.*?)(,)()[WITH] $1 $2
$4`
var substitution = " $1 $2\n$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}