using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d*)(.+?)(,)()";
string substitution = @" $1 $2\n$4";
string input = @"1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,
FIRST DISPLAY BLOCK REGEX COMMAND
[REPLACEALL](\d*)(.*?)(,)()[WITH] $1 $2
$4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}