# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d*)(.+?)(,)()"
test_str = ("1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,\n\n\n"
"FIRST DISPLAY BLOCK REGEX COMMAND\n\n"
"[REPLACEALL](\\d*)(.*?)(,)()[WITH] $1 $2\n"
"$4")
subst = " $1 $2\\n$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.