re = /(\d*)(.+?)(,)()/m
str = '1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,
FIRST DISPLAY BLOCK REGEX COMMAND
[REPLACEALL](\\d*)(.*?)(,)()[WITH] $1 $2
$4'
subst = ' $1 $2\\n$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result