// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d*)(.+?)(,)()").unwrap();
let string = "1MASS,2BLOCKCOUNT,3SECTOR,4SYSTEM,
FIRST DISPLAY BLOCK REGEX COMMAND
[REPLACEALL](\\d*)(.*?)(,)()[WITH] $1 $2
$4";
let substitution = " $1 $2\\n$4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}