# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\W]+)(\<\\/\b(a|b|em|i|strong)\b\>)/\2\1/g;t' <<< "<p>Lorem ipsum dolor sit <i>amet, </i>consectetur adipiscing elit.</p>"