using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\W]+)(\<\/\b(a|b|em|i|strong)\b\>)";
string substitution = @"\2\1";
string input = @"<p>Lorem ipsum dolor sit <i>amet, </i>consectetur adipiscing elit.</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}