package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\W]+)(\<\/\b(a|b|em|i|strong)\b\>)`)
var str = `<p>Lorem ipsum dolor sit <i>amet, </i>consectetur adipiscing elit.</p>`
var substitution = "\2\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}