use strict;
my $str = '<p>Lorem ipsum dolor sit <i>amet, </i>consectetur adipiscing elit.</p>';
my $regex = qr/([\W]+)(\<\/\b(a|b|em|i|strong)\b\>)/p;
my $subst = '\\2\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";