import re
regex = re.compile(r"([\W]+)(\<\/\b(a|b|em|i|strong)\b\>)")
test_str = "<p>Lorem ipsum dolor sit <i>amet, </i>consectetur adipiscing elit.</p>"
subst = "\\2\\1"
result = regex.sub(subst, test_str)
if result:
print(result)