import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\W]+)(\\<\\/\\b(a|b|em|i|strong)\\b\\>)";
final String string = "<p>Lorem ipsum dolor sit <i>amet, </i>consectetur adipiscing elit.</p>";
final String subst = "\\2\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}