const regex = /([\W]+)(\<\/\b(a|b|em|i|strong)\b\>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\W]+)(\\<\\\/\\b(a|b|em|i|strong)\\b\\>)', 'g')
const str = `<p>Lorem ipsum dolor sit <i>amet, </i>consectetur adipiscing elit.</p>`;
const subst = `\2\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);