re = /([\W]+)(\<\/\b(a|b|em|i|strong)\b\>)/
str = '<p>Lorem ipsum dolor sit <i>amet, </i>consectetur adipiscing elit.</p>'
subst = '\\2\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result