# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\w+)\W+(\w+)\W+(\w+)\h+(##(.+))$/$5|$1$4|$2$4|$3/gm;t' <<< "quirky, stable, fun ##Paul and Jill
mean, rude, sad ##Dave
rich, foolish, gorgeous ##Amanda"