#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\w+)\W+(\w+)\W+(\w+)\h+(##(.+))$"
Local $sString = "quirky, stable, fun ##Paul and Jill" & @CRLF & _
"mean, rude, sad ##Dave" & @CRLF & _
"rich, foolish, gorgeous ##Amanda"
Local $sSubst = "$5|$1$4|$2$4|$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)