use strict;
my $str = 'quirky, stable, fun ##Paul and Jill
mean, rude, sad ##Dave
rich, foolish, gorgeous ##Amanda';
my $regex = qr/^(\w+)\W+(\w+)\W+(\w+)\h+(##(.+))$/mp;
my $subst = '$5|$1$4|$2$4|$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";