// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w+)\W+(\w+)\W+(\w+)\h+(##(.+))$").unwrap();
let string = "quirky, stable, fun ##Paul and Jill
mean, rude, sad ##Dave
rich, foolish, gorgeous ##Amanda";
let substitution = "$5|$1$4|$2$4|$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}