import re
regex = re.compile(r"^(\w+)\W+(\w+)\W+(\w+)\h+(##(.+))$", flags=re.MULTILINE)
test_str = ("quirky, stable, fun ##Paul and Jill\n"
"mean, rude, sad ##Dave\n"
"rich, foolish, gorgeous ##Amanda")
subst = "$5|$1$4|$2$4|$3"
result = regex.sub(subst, test_str)
if result:
print(result)