import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+)\\W+(\\w+)\\W+(\\w+)\\h+(##(.+))$";
final String string = "quirky, stable, fun ##Paul and Jill\n"
+ "mean, rude, sad ##Dave\n"
+ "rich, foolish, gorgeous ##Amanda";
final String subst = "$5|$1$4|$2$4|$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}