import Foundation
let pattern = ###"^(\w+)\W+(\w+)\W+(\w+)\h+(##(.+))$"###
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"""
quirky, stable, fun ##Paul and Jill
mean, rude, sad ##Dave
rich, foolish, gorgeous ##Amanda
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$5|$1$4|$2$4|$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)