using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+)\W+(\w+)\W+(\w+)\h+(##(.+))$";
string substitution = @"$5|$1$4|$2$4|$3";
string input = @"quirky, stable, fun ##Paul and Jill
mean, rude, sad ##Dave
rich, foolish, gorgeous ##Amanda";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}