package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+)\W+(\w+)\W+(\w+)\h+(##(.+))$`)
var str = `quirky, stable, fun ##Paul and Jill
mean, rude, sad ##Dave
rich, foolish, gorgeous ##Amanda`
var substitution = "$5|$1$4|$2$4|$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}