# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bif\s*\(.*?\)\s*\{\s*([\s\S]*?);\s*}/$1/gm;t' <<< "if (log.isEnabled()) {
log.write(\"Log message with variable: %s
bar \", var);
}
if (log.isEnabled()) {
log.write(\"Log message with variable: %s \", var);
}
if (log.isEnabled()) {
log.write(\"Log message with variable: %s \", var);
}"