const regex = /\bif\s*\(.*?\)\s*\{\s*([\s\S]*?);\s*}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bif\\s*\\(.*?\\)\\s*\\{\\s*([\\s\\S]*?);\\s*}', 'gm')
const str = `if (log.isEnabled()) {
log.write("Log message with variable: %s
bar ", var);
}
if (log.isEnabled()) {
log.write("Log message with variable: %s ", var);
}
if (log.isEnabled()) {
log.write("Log message with variable: %s ", var);
}`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);