re = /\bif\s*\(.*?\)\s*\{\s*([\s\S]*?);\s*}/m
str = 'if (log.isEnabled()) {
log.write("Log message with variable: %s
bar ", var);
}
if (log.isEnabled()) {
log.write("Log message with variable: %s ", var);
}
if (log.isEnabled()) {
log.write("Log message with variable: %s ", var);
}'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result