import Foundation
let pattern = #"\bif\s*\(.*?\)\s*\{\s*([\s\S]*?);\s*}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
if (log.isEnabled()) {
log.write("Log message with variable: %s
bar ", var);
}
if (log.isEnabled()) {
log.write("Log message with variable: %s ", var);
}
if (log.isEnabled()) {
log.write("Log message with variable: %s ", var);
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)