package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bif\s*\(.*?\)\s*\{\s*([\s\S]*?);\s*}`)
var str = `if (log.isEnabled()) {
log.write("Log message with variable: %s
bar ", var);
}
if (log.isEnabled()) {
log.write("Log message with variable: %s ", var);
}
if (log.isEnabled()) {
log.write("Log message with variable: %s ", var);
}`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}