#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bif\s*\(.*?\)\s*\{\s*([\s\S]*?);\s*}"
Local $sString = "if (log.isEnabled()) {" & @CRLF & _
" log.write("Log message with variable: %s" & @CRLF & _
" bar ", var);" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"if (log.isEnabled()) {" & @CRLF & _
" log.write("Log message with variable: %s ", var);" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"if (log.isEnabled()) {" & @CRLF & _
" log.write("Log message with variable: %s ", var);" & @CRLF & _
"}"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)