import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bif\\s*\\(.*?\\)\\s*\\{\\s*([\\s\\S]*?);\\s*\\}";
final String string = "if (log.isEnabled()) {\n"
+ " log.write(\"Log message with variable: %s\n"
+ " bar \", var);\n"
+ "}\n\n\n"
+ "if (log.isEnabled()) {\n"
+ " log.write(\"Log message with variable: %s \", var);\n"
+ "}\n\n"
+ "if (log.isEnabled()) {\n"
+ " log.write(\"Log message with variable: %s \", var);\n"
+ "}";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}