using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bif\s*\(.*?\)\s*\{\s*([\s\S]*?);\s*}";
string substitution = @"$1";
string input = @"if (log.isEnabled()) {
log.write(""Log message with variable: %s
bar "", var);
}
if (log.isEnabled()) {
log.write(""Log message with variable: %s "", var);
}
if (log.isEnabled()) {
log.write(""Log message with variable: %s "", var);
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}