$re = '/\bif\s*\(.*?\)\s*\{\s*([\s\S]*?);\s*}/m';
$str = 'if (log.isEnabled()) {
log.write("Log message with variable: %s
bar ", var);
}
if (log.isEnabled()) {
log.write("Log message with variable: %s ", var);
}
if (log.isEnabled()) {
log.write("Log message with variable: %s ", var);
}';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;