// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bif\s*\(.*?\)\s*\{\s*([\s\S]*?);\s*}").unwrap();
let string = "if (log.isEnabled()) {
log.write(\"Log message with variable: %s
bar \", var);
}
if (log.isEnabled()) {
log.write(\"Log message with variable: %s \", var);
}
if (log.isEnabled()) {
log.write(\"Log message with variable: %s \", var);
}";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}