# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bif\s*\(.*?\)\s*\{\s*([\s\S]*?);\s*}"
test_str = ("if (log.isEnabled()) {\n"
" log.write(\"Log message with variable: %s\n"
" bar \", var);\n"
"}\n\n\n"
"if (log.isEnabled()) {\n"
" log.write(\"Log message with variable: %s \", var);\n"
"}\n\n"
"if (log.isEnabled()) {\n"
" log.write(\"Log message with variable: %s \", var);\n"
"}")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.