#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([.?:;!…])( )([A-Z])"
Local $sString = "Here? some text " & @CRLF & _
"Here? Some text " & @CRLF & _
"Here! some text " & @CRLF & _
"Here! Some text " & @CRLF & _
"Here. some text " & @CRLF & _
"Here. Some text " & @CRLF & _
"Here… some text " & @CRLF & _
"Here… Some text "
Local $sSubst = "$1\n$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)