import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([.?:;!…])( )([A-Z])";
final String string = "Here? some text \n"
+ "Here? Some text \n"
+ "Here! some text \n"
+ "Here! Some text \n"
+ "Here. some text \n"
+ "Here. Some text \n"
+ "Here… some text \n"
+ "Here… Some text ";
final String subst = "$1\\n$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}