import Foundation
let pattern = #"([.?:;!…])( )([A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Here? some text
Here? Some text
Here! some text
Here! Some text
Here. some text
Here. Some text
Here… some text
Here… Some text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)