package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([.?:;!…])( )([A-Z])`)
var str = `Here? some text
Here? Some text
Here! some text
Here! Some text
Here. some text
Here. Some text
Here… some text
Here… Some text `
var substitution = "$1\n$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}