const regex = /([.?:;!…])( )([A-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([.?:;!…])( )([A-Z])', 'gm')
const str = `Here? some text
Here? Some text
Here! some text
Here! Some text
Here. some text
Here. Some text
Here… some text
Here… Some text `;
const subst = `$1\n$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);