// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([.?:;!…])( )([A-Z])").unwrap();
let string = "Here? some text
Here? Some text
Here! some text
Here! Some text
Here. some text
Here. Some text
Here… some text
Here… Some text ";
let substitution = "$1\\n$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}