$re = '/([.?:;!…])( )([A-Z])/m';
$str = 'Here? some text
Here? Some text
Here! some text
Here! Some text
Here. some text
Here. Some text
Here… some text
Here… Some text ';
$subst = "$1\n$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;