import re
regex = re.compile(r"([.?:;!…])( )([A-Z])", flags=re.MULTILINE)
test_str = ("Here? some text \n"
"Here? Some text \n"
"Here! some text \n"
"Here! Some text \n"
"Here. some text \n"
"Here. Some text \n"
"Here… some text \n"
"Here… Some text ")
subst = "$1\\n$3"
result = regex.sub(subst, test_str)
if result:
print(result)