re = /([.?:;!…])( )([A-Z])/m
str = 'Here? some text
Here? Some text
Here! some text
Here! Some text
Here. some text
Here. Some text
Here… some text
Here… Some text '
subst = '$1\\n$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result