using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([.?:;!…])( )([A-Z])";
string substitution = @"$1\n$3";
string input = @"Here? some text
Here? Some text
Here! some text
Here! Some text
Here. some text
Here. Some text
Here… some text
Here… Some text ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}