using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@([a-zA-Z]+)[^:]+:(\d+)!([AD])!->(\d+)";
string substitution = @"";
string input = @"PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!->4000NM
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}