package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@([a-zA-Z]+)[^:]+:(\d+)!([AD])!->(\d+)`)
var str = `PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!->4000NM
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}