use strict;
my $str = 'PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!->4000NM
';
my $regex = qr/@([a-zA-Z]+)[^:]+:(\d+)!([AD])!->(\d+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";