re = /@([a-zA-Z]+)[^:]+:(\d+)!([AD])!->(\d+)/m
str = 'PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!->4000NM
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result