const regex = /@([a-zA-Z]+)[^:]+:(\d+)!([AD])!->(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@([a-zA-Z]+)[^:]+:(\\d+)!([AD])!->(\\d+)', 'gm')
const str = `PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!->4000NM
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);