import Foundation
let pattern = #"@([a-zA-Z]+)[^:]+:(\d+)!([AD])!->(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!->4000NM
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)