$re = '/@([a-zA-Z]+)[^:]+:(\d+)!([AD])!->(\d+)/m';
$str = 'PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!->4000NM
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;